1

Closed

ie webcontrols

description

The solution seems to depend on a signed Microsoft.Web.UI.WebControls.dll assembly, but cannot find it. I have gotten the source code for it from MS, built it, but cannot satisfy the references all over the place for the signed version (as the webcontrols source code doesn't come with the appropriate signing key--as it shouldn't). That WebControls assembly is pretty much orphaned by MS, is there a newer-hipper control library that can be used?
Closed Aug 17, 2007 at 8:51 AM by MINAS
Component not required. Config entry removed as per Greg's comments.

comments

gregdavisfromnj wrote Aug 9, 2007 at 3:00 PM

Here's a workaround...

Copy the built-unsigned Microsoft.Web.UI.WebControls.dll to the Source/ESB/Solutions/Man/Management/ESB.Management.Portal/Bin directory

Then comment out the "add" element on line 96 of the management portal's web.config file

Then remove the public key qualifier from the Assembly attribute of the Register directives on lines 1 and 6 of ManagementTreeView.aspx

No need to recompile, the website at localhost/esb/source/management/default.aspx loads okay it seems.

MINAS wrote Aug 17, 2007 at 8:50 AM

Hi Greg, There's no longer a dependency on that component. It was removed a few months ago.Sorry for the inconvenience.I've removed the config entry. I've not had the problem myself, so am puzzled as to what's different.Anyway, in the next build, it'll be gone :)Thanks

wrote Aug 17, 2007 at 8:51 AM

wrote Feb 14, 2013 at 8:11 PM

wrote May 16, 2013 at 9:54 AM