This project is read-only.

File missing from 6.2.9.0?

Topics: Developer Forum
Mar 26, 2009 at 10:37 PM
In the configuration file \ESB.NET\6.2.9.0_x64\Source\ESB\Base\Solutions\Main\Configuration\XMLConfigFiles\ESB.Core.Envelopes.config, there is reference to a DLL that is not included in the install:
                <Envelope>
                    <ObjectName>ESB.Adaptors.Envelopes.ESBMessageEnvelope.ESBMessageEnvelope.ESBMessageEnvelopeProvider</ObjectName>
                    <AssemblyPath>Envelopes\ESB.Adaptors.Envelopes.ESBMessageEnvelope\bin\ESB.Adaptors.Envelopes.ESBMessageEnvelope.dll</AssemblyPath>
                    <SchemaPath>Envelopes\ESB.Adaptors.Envelopes.ESBMessageEnvelope\XMLSchemas\1.0.0.0\ESBMessageEnvelope.xsd</SchemaPath>
                    <SchemaRootElement>ESBMessageEnvelope</SchemaRootElement>
                </Envelope>

I believe this is why I am getting an error when attempting to build a configured adaptor.
When I try to 'Display Request' from the Generic Request Sender screen or I try to 'Sample Request' from the Service Pipeline screen, I get the error below.
Is ESBMessageEnvelope.dll supposed to be available or do I have something configured wrong?

Server Error in '/ESB/Source/Management' Application.

Could not load file or assembly 'file:///D:\Visual Studio\ESB.NET\6.2.9.0_x64\Source\ESB\Envelopes\ESB.Adaptors.Envelopes.ESBMessageEnvelope\bin\ESB.Adaptors.Envelopes.ESBMessageEnvelope.dll' or one of its dependencies. The system cannot find the file specified.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'file:///D:\Visual Studio\ESB.NET\6.2.9.0_x64\Source\ESB\Envelopes\ESB.Adaptors.Envelopes.ESBMessageEnvelope\bin\ESB.Adaptors.Envelopes.ESBMessageEnvelope.dll' or one of its dependencies. The system cannot find the file specified.


Mar 27, 2009 at 11:56 AM
Edited Mar 27, 2009 at 12:04 PM

Hi,
1)Correct. The ESB.Adaptors.Envelopes.ESBMessageEnvelope.dll is missing. I'll fix that in the next release. Thanks.
2)You can just open up the .vbproj project and build it. Should all be good after that.
3)Note that this is NOT the default envelope. You can use the Default Envelope ESBEnvelope if you like to aid in your troubleshooting. The EBEnvelope ships with the core. The ESBMessageEnvelope ships as a standalone envelope & is an example of how to roll your own envelope...

 4)This is NOT the main reason your handler is not working. See original thread for that reason.

Cheers
Minas