This project is read-only.

Management console not working

Topics: Developer Forum
Feb 16, 2011 at 1:57 PM
Edited Feb 17, 2011 at 9:27 AM

After running the install scripts (the .msi did not work for me), I am only getting the browser error "could not connect to the website" when I try to access the management console (or when the script finishes and does this automatically). When I looked into the IIS Manager, there was no site configured on the server, only the esb application pools were added. Also, I noticed the following error in eventviewer:

The queue ComputerName\private$\esb.S_7.0.66.0.requestq was not found. It may have been deleted. The trigger ESBNETAsyncProcessingTrigger associated with this queue is nonfunctional. Please use Computer Management to remove this trigger.

Does this error have something to do with my problems? Is there a way to set up the Management console manually? Thank you. 

I am running Windows 7 x64 Professional + IIS 7 and my SQL Server 2008 instance name is different from localhost\esb, but I edited the setup files to take this into account.

Trying to diagnose the problem produces this log entry:

 

The Network Diagnostics Framework has completed the diagnosis phase of operation. The following repair option was offered:

Helper Class Name: TransportConnection

Root Cause: The remote device or resource won't accept the connection

The device or resource (localhost) is not set up to accept connections on port "The World Wide Web service (HTTP)".

Root Cause Guid: {91209b3b-0ce4-47fb-9d81-7e6162977ea3}

Repair option: Contact your network administrator

The computer or device you are trying to reach is available, but it doesn’t support what you’re trying to do. This might be a configuration issue or a limitation of the device.

RepairGuid: {dab3d3d3-7a9e-4a4f-9542-e0aa1cd81ad7}

Seconds required for repair: 0

Security context required for repair: 0

Interface: ({00000000-0000-0000-0000-000000000000})

Feb 17, 2011 at 8:34 AM

Hi Watto,

It seems as if either:

1)You're not running installer as an administrator

see: http://keystrokeesbnet.codeplex.com/wikipage?title=%5bESB.NET%20installation%5d&referringTitle=Installation

point 1a.

Basically, in the shortcut to startup a command prompt, ensure you do something like:

on the command prompt shortcut, right button -->run as administrator

or any other equivalent etc.

or

2)There's an issue with the pre-requisite setup

see: http://keystrokeesbnet.codeplex.com/wikipage?title=%5bPre-requisites%20verification%2fconfiguration%5d&referringTitle=Installation

 

Let me know how you go.

Cheers Minas

Feb 17, 2011 at 9:21 AM
Edited Feb 17, 2011 at 9:49 AM

Hi Minas,

thanks for your reply. I am sure the installer ran with administrator privileges, as did the manual installation script (Setup_ESB_FirstTime and Add_ESB_Instance). I believe that all the prerequisites were installed sucessfully. I should probably note that when I tried to install ESB.NET for the first time, it was probably not with the administrator privileges, and with invalid parameters (the sql server instance name specified in the setup differs from the one I have). I uninstalled it and tried to reinstall, but without success. Is it possible that some registry entries point to an invalid path because of this? Or could some leftover files and settings from previous installation affect current installation?

Anyway, if it is possible to set up the management console site using the IIS Manager, could you advise me how to do that, please? What virtual directories need to be set up, what application(s) should be hosted, etc.?

Feb 17, 2011 at 10:15 AM

Hi Watto,

There's a bunch of things we can check to help nail this.

  • Usually it's something with the Environment that's the issue. Fortunately, most of this is covered in the doco here online already.
  • The SQL server parts won't stop the EMC, V.Dirs & AppPools from being setup in IIS.
  • There may be some IIS metabase issues that need correcting.

Please work through the list below. This should help us get to a known envrionment baseline.

Once the baseline is established, run the AddInstance.cmd batch file to setup an ESB instance. Setup_ESB_FirstTime.cmd just sets up the DB and the Windows User accounts, so we can ignore this piece for the moment. We can run separate scripts later to address this.

Checklist

1) Does IIS work for other virtual directories?

i.e. do you have any other web apps running on this install?

2) Can you create an IIS v.dir manually - anything.

3) Has IIS got all the appropriate features installed?

see: http://keystrokeesbnet.codeplex.com/wikipage?title=%5bPre-requisites%20verification%2fconfiguration%5d&referringTitle=Installation

point 5 - for the list of IIS features required.

4) Are the Windows Users & passwords correctly set on the App Pools?

ESBServiceUserPassword = Service3SB by default

ESBManagementUserPassword = Management3SB by default

4.1) Go into User Management & set the passwords to the above

4.2) Go into IIS manager & set the passwords for each AppPool according to the appropriate Username.

 

5) IIS configuration fix:

see: http://keystrokeesbnet.codeplex.com/wikipage?title=%5bPost%20setup%20tasks%20-%20First%20time%20install%5d&referringTitle=Installation

including the section on: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

 

HTH

Cheers Minas

You can get me on MSN Messenger, on minas_casiou@hotmail.com, if you've worked through the above and are still having issues.

Feb 17, 2011 at 2:46 PM

I eventually solved the problem by uninstalling IIS, then the .NET Framework 4, installing IIS and .NET Framework 4.

Feb 18, 2011 at 7:24 AM

Hehe. Great.

Let me know if you have any more issues.

Cheers Minas